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By Christine Cummings 
LabSmith, Inc. Livermore, CA 94550 

This application note describes how to use the 
uProcess™ thermal devices, including tips for getting 
the best results from your sensors and controllers, 
and detailed temperature regulation examples. 

Introduction 

uProcess™ uTS temperature sensors, uTE thermal 
module, and uProcess software make it easy to monitor 
and control your micro-process application. For the 
examples below, the temperature is measured on the 
top surface of a glass microscope slide that is bonded to 
the uTE thermal module. An additional temperature 
sensor is used to record the temperature on the back 
side of the module (between the Peltier and the heat 
sink).  

Table 1 and Figure 1 show the equipment used in this 
application: 

Table 1. Components 

LabSmith Part 
Number 

Description Qty 

uPB-5 uProcess Breadboard  1 

EIB200 Electronic Interface Board 1 

4PM01 4 Channel Power Manifold 1 

4AM01 4 Channel Analog Manifold 1 

uTE01 -132020 Thermo-electric Peltier module 1 

2020HS Heat sink for uTE01 1 

uTS01-STD Temperature Sensor 2 

- M2-6 screw 2 

LS-Screws.25 2-28x1/4” screws 2 

- Glass Microscope Slide 1 

- Thermal Tape ~10 cm 

 

 

Figure 1. Experimental setup. 

Set up the uProcess Breadboard 

1) Prepare the uTE01 Peltier: 

a) Cover the back side of the uTE01 Peltier with 
thermal tape, preferably using tape that is at 
least 0.25mm thick. 

 

b) Attach the end of a uTS01-STD temperature 
sensor to the thermal tape and cover with a 
2020HS heat sink. Make sure the heat 
sink/thermal tape interface has good contact 
across the entire Peltier surface. 

c) Connect the glass microscope slide to the front 
side of the uTE01 Peltier using thermal tape. 

d) Connect the end of a uTS01-STD temperature 
sensor thermocouple to the top of the glass 
microscope slide using thermal tape. 
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e) The completed assembly should look like 
this: 

 

2) Attach the uTE01 controller to the breadboard 
using two M2 screws. 

3) Attach the uTS01 sensors to the breadboard using 
one 2-28x1/4” screw for each sensor. 

4) Plug the EIB200 into a breadboard connector. 

5) Plug the 4PM manifold into a breadboard 
connector. 

6) Use the flat flex ribbon cable to connect the 4PM01 
to the uTE01 controller. 

NOTE:  Refer to the label on the 4PM and the uTE01 
drawing below to make sure the cable 
orientation is correct for both sides. 

 

7) Plug the 4AM manifold into a breadboard 
connector. 

8) Use the flat flex ribbon cables to connect the 4AM to 
the uTS01 sensors. 

Set up the Experiment in uProcess Software 

1) Connect the EIB200 to your computer via the micro-
USB cable (provided with the EIB200). 

2) Connect power to the EIB200 and start the uProcess 
software. 

3) Right-click on Interfaces and select New Interface… 
to connect to the EIB200 (see the uProcess Quick 
Start Guide for detailed instructions).  

4) The uProcess software screen should look similar to 
the following:  

 

Set the uTE01 Load Type 
When using a uTE01 load, the load configuration must 
be set in uProcess.  

5) To set the load configuration, click on the 4PM icon 
in the Interface tree to bring up the 4PM Module 
window. 

 
6) Click on the Load button for the channel to which 

the uTE01 is connected (in this case channel 1, 
or Load1). 
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7) Using the dropdown menus, set the Load type to 
uTE Peltier, and then select the appropriate Subtype 
from the dropdown window.  

8) Optional: Change the Name for more description. 
For example, since a 13-2020 uTE Peltier is used, the 
Name is changed to uTE2020. 

NOTE:  The Load settings are saved in the 4PM memory. 
If a different type of load is used in the 4PM 
channel, or if the load is moved to a different 
channel, the 4PM Load Configuration must be 
updated. The Load Configuration sets the 
channel voltage and power limits; using an 
incorrect configuration can damage the uTE01 
Peltier. 

Set the uTS Sensor Name 
9) The factory setting for the temperature sensors uses 

the sensor serial number as the sensor name. If 
desired, rename your temperature sensors based on 
their placement location. This is especially useful if 
more than one sensor is used, such as the 2 sensors 
used in this application. 

a) The uTS located on top of the chip is renamed 
“target”. 

a) The uTS located between the Peltier and heat 
sink is renamed “heat sink”. 

10) To change the sensor name, click on the 4AM in the 
Interface tree and select Configuration…. 

 

11) Select the correct sensor under Sensor Properties 
and change the sensor name (trace the 
communication cable back from the 4AM to each 
uTS to be sure you have selected the correct sensor). 

 

Your setup is now ready to start controlling 
temperatures.  
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NOTE:  The uTE can be easily damaged if the 
temperature on either side of the Peltier 
exceeds the maximum ratings. Unregulated 
control should be closely monitored to ensure 
temperatures stay within the limits.  

Measure the Thermal Response Lag Time 

The response lag time is the time delay between 
applying power to the uTE controller and when the 
temperature change is observed at the target location. 
The uTE controllers are shipped with a default thermal 
response lag time of 0.5 seconds. The actual lag time is 
application dependent and will vary with the location of 
the thermal sensor. For the most accurate temperature 
feedback control, the lag time should be measured and 
adjusted for each application.  

For this example, the uTS temperature sensor (renamed 
‘target’) is attached at the target location.  

1) To measure the thermal lag time, select File>Log 
Status/Measurements… to start recording a log file. 
Select a file name and location when prompted to 
enter (if not prompted, the log is set as autoname; 
go to View>Status/Meas Logging Options… to 
change). 

2) Click on the 4PM in the interface tree to bring up the 
4PM uDevice™ window. 

3) Select Power in the Regulation dropdown menu to 
set the regulation mode to constant power. 

4) Set the power to 2W and apply settings using the 
Apply All Settings Now button ( ). 

5) The target temperature will rise, and the heat sink 
temperature will fall. Wait until the target 
temperature has increased approximately 10°C then 
click Stop All uDevices ( ). 

6) Go to File>Log Status/Measurements… to uncheck 
and stop recording the log file. 

7) Open the Log File in Microsoft Excel or another data 
processing software. Plot the target temperature 
and current vs. time. If your uTE is plugged into 
channel 1 of your 4PM, select Current 1. Note the 
time from when the power is stopped to when the 
temperature stops rising. This is your thermal 
response lag time. The figure below shows an 
example lag time of 3 seconds. 

 

8) Select the 4PM from the Interface tree to bring up 
the 4PM control window. 

 

9) Click on the Load Configuration and select the 
appropriate load (13-2020 in this example).  
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10) Change the System response lag time to the correct 
value and click OK. 

Selecting a Voltage Ramp Rate for 
Temperature Regulation  

When regulating temperatures, the voltage ramp rate 
(V/s) can be adjusted to optimize temperature ramp 
rate, overshoot, and error. The figure below shows 
various voltage ramp rates for a set temperature of 60°C. 

 

If precise temperature regulation is required, use a low 
the voltage ramp rate (~0.001–0.005 V/s). If the time to 
reach the set temperature is crucial, a higher ramp rate 
should be used (~0.01 V/s). 

If both speed and accuracy are critical, a multi-step 
regulation routine can be written (refer to Example 3).  

Active vs. Passive Cooling 

The uProcess thermal products support both active 
cooling and passive cooling. The default voltage 
settings for the uTE controllers allow both positive and 
negative voltage for heating and cooling, respectively. 
Caution must be used with active cooling (negative 
voltage), as the back side of the Peltier module can 
easily be overheated if the steps are not taken to cool 
the module. If active cooling is to be used, it is best to 
use a heat sink, fan, and a temperature sensor mounted 
between the Peltier and heat sink.  

Passive cooling is sufficient for many applications where 
the application temperatures are above ambient. With 
passive cooling, the uTE controller minimum voltage is 
set to 0, and the uTE voltage is reduced or turned off. 
This eliminates the possibility of overheating the back 
side of the uTE Peltier.  

Changing the uTE controller voltage settings: 

1) Click on the 4PM in the Interface tree to bring up the 
4PM uDevice Window. 

 

2) Select the load to change (in this case uTE2020). 
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3) Change the minimum voltage to 0 and click OK. 

Example 1: Maintaining a Set Temperature 

This application shows how to use the uTE controller 
and uTS sensor to maintain a constant, set temperature.  

The automated script uses the uTE to regulate the 
“target” thermocouple temperature to 37.5°C. 

This example is optimized for temperature precision 
rather than expedient changes in temperature. Using a 
voltage ramp rate of 0.001 V/s will minimize overshoot. 

1) Click on Interfaces in the uDevices tree to view the 
uDevice window. 

  

2) Click on the Reg… box next to the target 
temperature listing to bring up the Regulation 
Settings window. 

3) Using the dropdown menu, change the uTE Peltier 
load to To Ch A. 

4) Set the uTE voltage ramp rate to 0.001 V/s. 

5) Set the regulation settings as shown in the following 
window and click OK. 

 

NOTE:  Hysteresis is not typically used with temperature 
regulation. Checking the Hysteresis box would 
force the regulation routine to regulate towards 
the far tolerance limit (if regulating up, it would 
regulate to the the maximum limit, if regulating 
down it would regulate to the minimum limit). 
This is often desirable for pressure regulation 
but will cause instability and overshoots for 
temperature regulation. 

6) Click on Save as New Sequence Step ( ) and click 
OK to save the settings to the script. 
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7) Click on Sequencing Script in the Sequencer tree to 
view the Sequence Window and see the script. This 
script will regulate the target temperature up (or 
down) to 37.5°C and maintain that temperure until 
the script is stopped. 

 

8) Go back to the uDevice window (click on Interfaces 
in uDevice tree) to monitor temperatures before 
starting the script. 

9) Run the sequence program ( ).  

10) Press Stop all uDevices ( ) to stop the regulation. 

NOTE:  Each uTS temperature sensor includes a 
compensation temperature sensor that is 
located in the uTS body. This compensation 
measurement is used as the ambient 
temperature measurement in this example. The 
compensation temperature can be monitored 
via the 4AM uDevice Window (as shown below) 

and is included in the log data file as ‘Comp 
Temp.’ 

 

11) The figure below shows a typical data set from 
Example 1.  

 

Example 2: Switching Between Two Set 
Temperatures 

Example 2 shows how to use the uTE controller and uTS 
sensor to rapidly switch between two temperature 
settings, 90°C and 50°C, at 5-minute intervals. 

A voltage ramp rate of 0.01 V/S is used to optimize 
temperature ramp rate rather than precision. 

1) Click on Interfaces in the uDevices tree to view the 
uDevice window. 
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2) Using the dropdown menu, set the uTE Peltier load 
to “To Ch A.” 

3) Set the uTE voltage ramp rate to 0.01 V/s. 

4) Click on the Reg… box next to the target 
temperature listing to bring up the Regulation 
Settings window. 

5) Set the target reading to 90°C and click OK. 

 

6) Click on Save as New Sequence Step ( ) and 
change the setting to Pause. Leave the time at 4000 
ms (this will be changed directly in the script). Click 
OK to save the settings. 

 

7) Click on the Reg… box next to the target 
temperature listing to bring up the Regulation 
Settings window. 

8) Change the Target reading to 50°C and click OK. 

 

9) Click on Save as New Sequence Step ( ). Set the 
pause time to 4000 ms and select Loop to Step. 
Change the loop to Step1 for 3 times click OK. 

 

10) Select Sequencing Script to view the script. The 
script should look similar to the following: 

*target = uTS01 
*LabSmith_4AM = 4AM01 
*LabSmith_4PM = 4PM01 
Step1: 
 LabSmith_4PM: SetPerChannel(Out1, DChA, 0.01000 V/s) 
 target: RegBetween(88.000 C, 92.000 C, DChA) 
 Wait(4000 ms) 
Step2: 
 LabSmith_4PM: SetPerChannel(Out1, DChA, 0.01000 V/s) 
 target: RegBetween(48.000 C, 52.000 C, DChA) 
 Wait(4000 ms) 

Loop Step1 3 

 

The script will start to regulate the target temperature to 
90°C. After 4 seconds it will start to regulate down to 
50°C. This cycle will be repeated for a total of 3 
iterations. At this point, the script will be complete, but 
the uTE will continue to regulate to 50 °C (the last 
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setting) until the script is manually stopped by pressing 
Stop All uDevices ( ). 

Two changes will improve the script: 

• An end condition added to turn off the 
regulation after the script is done. 

• The pause time can be adjusted to 5 minutes. 
The pause clock will not start until the target 
temperature is in range. 

11) To add the end condition, click on Stop this Device 
located in the 4PM panel. 

 

Then, click on Save as New Sequence Step ( ) before 
clicking OK to create Step3. 

12) Click Sequencing Script to bring up the sequencing 
script control window. Delete ‘4000 ms’ and type ‘5 
min’ in both Step1 and Step2. 

13) Adding a WaitDone() command before the <Pause> 
command will delay the start of the <Pause> timer 
until the target temperature reaches the specified 
temperature range. 

14) The sequencing script should now match the 
following (items changed are in bold): 

*target = uTS01 
*LabSmith_4AM = 4AM01 
*LabSmith_4PM = 4PM01 
Step1: 
 LabSmith_4PM: SetPerChannel(Out1, DChA, 0.01000 V/s) 
 target: RegBetween(88.000 C, 92.000 C, DChA) 
 WaitDone() 
 Wait(5 min) 
Step2: 
 LabSmith_4PM: SetPerChannel(Out1, DChA, 0.01000 V/s) 
 target: RegBetween(48.000 C, 52.000 C, DChA) 
 WaitDone() 
 Wait(5 min) 
Loop Step1 3 
 
Step3: 
 LabSmith_4PM: Stop() 

 WaitDone() 

 
15) Go back to the uDevice window (click on Interfaces 

in uDevice tree) to monitor temperatures before 
starting the script. 

16) To log the temperature data, click on File>Log 
Status/Measurements… to open a log file. uProcess 
will prompt you to name the file, unless uProcess is 
set to autoname the file in View>Status Meas 
Logging Options… 

17) Run the sequence program ( ). The graph below 
shows the dataplot obtained using this example 
code. 
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